Gamoover

[move]Vous aimez le couscous-boulettes, le chorizo, la Force 4, et la mimolette ? Alors soyez les bienvenus sur Gamoover ! [/move]

Menu

Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.

Voir les contributions Menu

Messages - ldindon

#49
Bornes dédiées / [WIP] Space Invaders Taito
Mardi 28 Février 2023, 19:32:55 PM
Citation de: zebassprophet le Mardi 28 Février 2023, 17:19:05 PMtiens ldindon
t'as pas des transistors de BU pour SI qui traine :D

J'ai récupéré quelques BU au boulot mais je doute que j'ai la bonne référence. C'est quoi que tu cherches ?
De toute façon je pense que ma platine en aura besoin. Mais de ce que j'ai vu ce n'est pas la même que sur ta Midway.
#50
Bornes dédiées / [WIP] Space Invaders Taito
Lundi 27 Février 2023, 20:28:03 PM
Citation de: Little_Rabbit le Lundi 27 Février 2023, 16:04:54 PMVoilà une belle avancée sur le plan des sons !  ^-

Merci :). Ca sent bon et je devrais pouvoir arriver au bout de cette réparation.

Citation de: Little_Rabbit le Lundi 27 Février 2023, 16:04:54 PMCe qui est curieux, c'est que tu as en boucle le son qui me semble être celui qui apparaît normalement quand tu touches le "mystery ship".

Oui c'est le son UFO HIT qui tourne en boucle, celui qui doit être joué lorsque l'on détruit la "mystery ship".

Citation de: Little_Rabbit le Lundi 27 Février 2023, 16:04:54 PMJe pense que la partie qui génère le "bruit blanc" utilisé pour "salir" tous les sons d'explosion et de tir est également défaillante.

Qu'est-ce qui te fait dire ça ?

Citation de: Little_Rabbit le Lundi 27 Février 2023, 16:04:54 PM[edit : les LM3900 et le NE556 sont des composants très courants, tu les aurais facilement trouvés en France ;). Après, je ne sais pas si c'est plus économique via AliExpress... Niveau CO2, c'est quand même moins bien :D ;) ]

Clairement beaucoup moins cher chez AliExpress mais oui c'est mal pour le CO2  :(. Un total de 26 € chez E44 contre 9,55 € chez Ali.

Citation de: Little_Rabbit le Lundi 27 Février 2023, 16:04:54 PM[edit2 : je ne sais pas si c'est le cas sur le schéma Taito, mais sur le schéma Midway, il y a un inversion au niveau de l'intitulé de deux des sons : Invader hit et Saucer hit ! ;) J'en parlais sur ce WIP.]

Pas de soucis sur le schéma de la version Taito, respectivement « TARGET HIT » et « UFO HIT » ;)

#51
Bornes dédiées / [WIP] Space Invaders Taito
Dimanche 26 Février 2023, 14:42:53 PM
Comme je suis chaud aujourd'hui j'ai continué un peu. Je suis entré dans le mode test en activant le dip 4. C'est sympa car les sons sont joués un derrière l'autre.

Voici mes conclusions:

- AMP0: IC24 (76477): UFO: OK
- AMP1: IC28 + IC30: TRIGGER: NO SOUND
- AMP2: IC28: FLASH: NO SOUND (explosion PLAYER)
- AMP3: IC31 + IC32: TARGET HIT: OK
- AMP4: IC29 (LM556): EXTENDED PLAY: OK
- AMP5: IC29 (LM556): STEP: NO SOUND
- AMP6: IC33 + IC34: UFO HIT: CONTINUOUS

C'est en jouant sur le potard VR7 que j'ai vu que le son en continu y était relié. Ce qui correspond à UFO HIT d'après mon manuel. Je ne sais pas pourquoi il tourne en boucle. Le signal SX10 est pourtant correct.

J'ai déssoudé IC31 et IC32 car ils sont bons. Oui ça peut paraître bizarre mais ça va me permettre de tester d'autres LM3900.

J'ai donc déssoudé IC34 qui fait partie du circuit UFO HIT. Je l'ai ensuite installé à la place de IC32. Puis j'ai constaté que je venais de perdre le son TARGET HIT. J'ai donc IC34 qui est HS.

Je vais procéder de même pour les autres LM3900 et en parallèle à ça je vais passer une commande en Chine.

Concernant le son dit STEP (les 4 notes qui accompagnent le déplacement des invaders), ils ne fonctionnent pas. Or ils sont générés par l'IC29 (un LM556). Ce même IC29 est aussi utilisé pour le son EXTENDED PLAY. Ce dernier est OK. C'est donc étrange...

EDIT: Commande de 10x LM3900 et 5x LM556 passée sur AliExpress. La suite à la réception des composants, au plus tard le 28 mars !
#52
Bornes dédiées / [WIP] Space Invaders Taito
Dimanche 26 Février 2023, 11:56:44 AM
Bon voilà ce matin j'ai fouillé dans mon stock de vieux composants récupérés à droite à gauche et j'ai trouvé quelques condensateurs 0.1 uF qui me paraissaient compatibles. J'en ai installé un orange tout joli après l'avoir mesuré (0.1 uF, 1.2 Ohms):



J'ai mis la PCB sous tension .... et pas d'explosion du condo ^-.

Je mets un crédit, j'appuie sur START et hop du son  ^-^ .


Par contre ce n'est pas le bon son pour la progression des envahisseurs et il manque des sons. Triste  mais très encourageant tout de même. J'ai fait une petite vidéo histoire que vous vous rendiez compte de ce qui ne va pas:


Bon ben je pense qu'il va falloir que je commande quelques LM3900.
#53
Bornes dédiées / [WIP] Space Invaders Taito
Dimanche 26 Février 2023, 11:40:27 AM
J'ai avancé ce matin. Je vous fait un petit retour d'ici quelques minutes  ;)
#54
Bornes dédiées / [WIP] Space Invaders Taito
Samedi 25 Février 2023, 20:16:37 PM
Citation de: Saturnin le Samedi 25 Février 2023, 18:34:39 PMQuel boulot ! Chapeau l'artiste, une véritable cure de jouvence pour cette admirable vieille dame ^-^

Merci @Saturnin  ^- Mais je pense que c'est loin d'être fini. Remettre en route la platine ça va être du sport  :-X

Sinon, vu que je n'ai pas de son du tout sauf quand je perds une vie (si on peut appeler ça du son) et que j'ai bien les triggers qui fonctionnent. Je me dis que le soucis se trouve forcément au niveau de l'amplification globale. C'est à dire ici:



J'imagine que SX5 est la fonction mute dont tu avais parlé @Little_Rabbit ?
On peut noter qu'au final tout passe par un LM3900 pour l'amplification globale avant de passer par un LM377. Donc si un de ces deux composant est HS pas de son.

A noter aussi qu'à la première page de ce WIP je dis que j'ai enlevé un condensateur car il avait une patte arrachée. C'est le gros vert sur cette photo. Je ne l'ai toujours pas remplacé, le problème vient peut-être de là ? En plus on est en plein dans cette ZONE  :-((


#55
Bornes dédiées / [WIP] Space Invaders Taito
Samedi 25 Février 2023, 17:13:27 PM
Je me suis focalisé sur le son du tir de notre vaisseau. Le signal est bien triggé au niveau de IC4 sur la pin 5:



Le signal reste bien à l'état haut tout le temps que le missile est visible. Ca passe bien aussi par IC8 avec une recopie de ce qui rentre en pin 3 pour sortir sur la pin 4.

Ensuite ça arrive sur la partie analogique en IC28 (signal SX1). la sortie 9 de IC28 est bien plate  >:(


#56
Bornes dédiées / [WIP] Space Invaders Taito
Samedi 25 Février 2023, 12:25:09 PM
Salut à tous, voilà enfin je peux m'y remettre !!!

Citation de: Little_Rabbit le Lundi 13 Février 2023, 14:53:46 PMTiens je ne connaissais pas ce mode test ! C'est spécifique à la version Taito ? Je n'ai pas le souvenir que SI en version Midway dispose d'un mode test.

C'est un test qui ressemble à celui de l'EPROM de test mais en beaucoup plus simple. J'ai trouvé les explications dans le manuel Taito de la borne. Il y a apparement quelques subtilités par rapport aux dip-switchs d'une révision de carte à une autre selon la doc. Aucune idée si c'est présent sur la version Midway mais pourquoi aurait-il supprimé une fonctionnalité si pratique ?


Citation de: Little_Rabbit le Lundi 13 Février 2023, 14:53:46 PMTes deux problèmes (pas de son et pas d'entrées) sont traitées sur la carte fille.

Bon ben pour les entrées c'était super simple... J'ai dû utiliser un connecteur plus grand (2x18 pins) pour la carte son (2x15 pins). Quand j'ai soudé les fils je me suis basé sur la fin du connecteur en oubliant ce détail. Regardez moi ça comme c'est beau  =:))



Après correction:



J'ai enfin pu me faire une petite partie  ^-:



Concernant le son, j'ai un « prout » à chaque fois que je perds une vie. Ca voudrait dire que l'ampli principal LM3777 est fonctionnel. J'arrive aussi à lui faire crachouiller des parasites en inspectant son entrée 8 à l'oscillo. Par contre sur 6, 7 et 9 ça ne fait pas de bruit. Les tensions sur les entrées du LM377 sont à environ 6V et ne bougent pas.

J'ai lu que les ampli LM3900 utilisés un peu partout sur cette carte audio ont tendance à lâcher. Est-ce qu'il existe une procédure simple pour les tester en circuit ?
#57
Bootlegs / Bootleg PCB Shinobi
Mercredi 15 Février 2023, 19:54:40 PM
Citation de: Little_Rabbit le Mercredi 15 Février 2023, 11:08:39 AM1 + 2 = GND
3 + 4 = +5V
5 = 12 V  => qui semble en effet aller vers le CI (Circuit Intégré) ampli audio !

Ca ne peut-être que ça. Car si c'était du Jamma le 12V se trouverait en 6. Or la piste qui part de la broche 6 n'est clairement pas une piste faite pour. De plus la broche sous la 6 devrait être reliée à celle-ci. Or on voit clairement qu'elles sont distinctes.
#58
Bootlegs / Bootleg PCB Shinobi
Mardi 14 Février 2023, 21:46:12 PM
Citation de: Little_Rabbit le Lundi 13 Février 2023, 20:02:52 PMMais je me demande si il ne peut pas aussi exister des versions JAMMA, et comment alors vous y prendriez-vous pour identifier à coup sûr le standard du brochage d'un bootleg ?

Je me disais peut-être qu'en cherchant les broches SPEAKER+ et SPEAKER-, en suivant les pistes, on devrait remonter jusqu'au circuit responsable de l'amplification audio, qui est assez caractéristique, avec souvent un radiateur ?

Ou alors vérifier si le 12V est sur F/6 ou E/5 en testant la continuité avec l'ampli audio.
#59
Bootlegs / Bootleg PCB Shinobi
Samedi 11 Février 2023, 21:26:28 PM
Citation de: Little_Rabbit le Samedi 11 Février 2023, 12:34:53 PMOn voit que les alimentations et masses (GND) sont au même endroit

Attention tout de même car le 12V du System 16 n'est pas au même endroit.
#60
Bornes dédiées / [WIP] Space Invaders Taito
Samedi 11 Février 2023, 19:47:10 PM
Citation de: Little_Rabbit le Samedi 11 Février 2023, 12:51:54 PMPour les sons, j'imagines que tu as bien vérifié le potard du volume ? :) Sur le PCB Taito, je crois même qu'il y a un potard individuel pour régler le volume de chacun des sons non ?

Oui un potard par son et un master.

Citation de: Little_Rabbit le Samedi 11 Février 2023, 12:51:54 PM- une fonction MUTE qui coupe tous les sons (quand elle est actionnée pour activer les sons, cela fait un "POC" dans le haut-parleur

Je vais regarder où elle se situe car j'ai souvent un "POC".

Citation de: Little_Rabbit le Samedi 11 Février 2023, 12:51:54 PMQuant à la ROM H, s'il ne suffit que de programmer une nouvelle EPROM, ce n'est pas méchant :). Et d'ailleurs, ce sont des ROM ou des EPROM qui sont en place ? Car il me semblait que pour l'un ou l'autre des cas, les jumpers doivent être configurés différemment non ?

J'ai programmé une AM2732B après avoir doublé le fichier binaire de la ROM H. J'ai utilisé tv0h.s1 de l'archive sitv. Dans mon cas je n'ai pas eu besoin de trifouiller les jumpers, le routage était compatible avec mes EPROMs. Et voilà le résultat  :D :



Le jeu tourne nickel (sans le son). Par contre je n'ai pas réussi à mettre des crédits. Soit j'ai un soucis avec mon câblage soit ça vient de la PCB.

A noter que j'ai pu activer le mode test de la PCB en mettant le switch 4 sur ON. Ca sera pratique pour tester l'audio sans avoir à réinstaller l'EPROMs de test.

Par contre je ne suis pas sûr de comprendre la section "CHECK INPORT". Est-ce qu'il s'agit bien du test des inputs du jeu (stick, bouton, crédit, ...) ? Si c'est le cas j'ai un soucis car j'ai toujours la même chose que j'appuie sur les inputs ou pas:

PORT1:
- 0: *
- 1: *
- 2: *
- 3
- 4: *
- 5: *
- 6: *
- 7

PORT2:
- 0
- 1
- 2: *
- 3
- 4: *
- 5: *
- 6: *
- 7
#61
Bornes dédiées / [WIP] Space Invaders Taito
Samedi 11 Février 2023, 12:26:47 PM
Voilà je viens de tester la ROM H sur l'emplacement de la E:



On a donc:

ROM H: 22C545F1

On est loin de 9f37b146 ou de fef18aad, de plus 22C545F1 est introuvable dans le fichier 8080bw.c  >:(

Elle est donc HS. Il va falloir que je la remplace.
#62
Bornes dédiées / [WIP] Space Invaders Taito
Samedi 11 Février 2023, 12:02:39 PM
ENFIN, j'ai reçu hier mon petit lot de DRAMs. Il ne faut pas être pressé mais vu le prix on ne va pas se plaindre.

C'est donc fébrilement au vue de mes mauvaises expériences passées avec les puces en provenance de Chine que je suis descendu ce matin pour tester tout ça.

Après une rapide vérification du banc de test, j'en insère une et je démarre sur l'EPROM de test. Elle est OK  ^-
Allez hop une deuxième, je démarre et elle est bonne aussi  ^-^. Donc à partir de là le reste c'est du bonus puisque je n'en avais besoin que de 2.

Je poursuis les tests des 8 autres une à une et vous n'allez pas me croire ... 10/10  :-)=
INCROYABLE !!! Est-ce qu'il faut que j'aille jouer au loto ?

Bon sinon, voici une photo de l'écran de test:



Je suis en train de chercher sur le net pour trouver les CRC. Ceux qui sont donnés dans la documentation de l'EPROM sont pour la version Midway. Je ne suis pas sûr que ça soit les mêmes que ceux de ma carte.

D'après la doc:
The CRC32 of the ROMs are extracted from mame  :
Space invaders (Bally Midway)
invaders.e 14e538b0
invaders.f 0ccead96
invaders.g 6bfaca4a
invaders.h 734f5ad8
 
Space invaders deluxe (Bally Midway)
invdelux.d e8d5afcd
invdelux.e 408849c1
invdelux.f f4aa1880
invdelux.g 4268c12d
invdelux.h e690818f

Les miens (je n'ai pas installé la ROM H pour l'instant):
ROM E: CD2C67F6
ROM F: 0AD3657F
ROM G: 3C759A90
ROM H: 08D43DFE (CRC de la ROM de test donc)

Et voici ce que j'ai trouvé pour le moment dans les sources de Mame:

ROM_START( sitv1 ) // rev 1
ROM_REGION( 0x10000, "maincpu", 0 )
ROM_LOAD( "tv01.s1",      0x0000, 0x0800, CRC(9f37b146) SHA1(0b7ef79dbc3de3beeae3bf222d086b60249d429f) )
ROM_LOAD( "tv02.rp1",     0x0800, 0x0800, CRC(3c759a90) SHA1(d847d592dee592b1d3a575c21d89eaf3f7f6ae1b) )
ROM_LOAD( "tv03.n1",      0x1000, 0x0800, CRC(0ad3657f) SHA1(a501f316535c50f7d7a20ef8e6dede1526a3f2a8) )
ROM_LOAD( "tv04.m1",      0x1800, 0x0800, CRC(cd2c67f6) SHA1(60f9d8fe2d36ff589277b607f07c1edc917c755c) )
ROM_END

et

ROM_START( sitv ) // rev 2, minor bug fixes of sitv1; delay when writing to sound latch 0x05, and another unknown change
ROM_REGION( 0x10000, "maincpu", 0 )
ROM_LOAD( "tv0h.s1",      0x0000, 0x0800, CRC(fef18aad) SHA1(043edeefe6a6d4934bd384eafea19326de1dbeec) )
ROM_LOAD( "tv02.rp1",     0x0800, 0x0800, CRC(3c759a90) SHA1(d847d592dee592b1d3a575c21d89eaf3f7f6ae1b) )
ROM_LOAD( "tv03.n1",      0x1000, 0x0800, CRC(0ad3657f) SHA1(a501f316535c50f7d7a20ef8e6dede1526a3f2a8) )
ROM_LOAD( "tv04.m1",      0x1800, 0x0800, CRC(cd2c67f6) SHA1(60f9d8fe2d36ff589277b607f07c1edc917c755c) )
ROM_END

Ca colle avec les miens. J'ai donc une TV version. Il ne me reste plus qu'à lire le CRC de la ROM H.

Sinon quelques infos supplémentaires:
  • Aucun son lors des tests
  • Le test des shifters est OK
  • Le jeu ne démarre pas avec la ROM H en place


#63
Bootlegs / Bootleg PCB Shinobi
Samedi 11 Février 2023, 10:30:10 AM
Tu peux prendre ça pour quelques centimes sur AliEpxress:

Il te suffit de couper les fils à 15 ou 20 cm de ton connecteur puis de les ressouder un à un sur cette plaque.
Il faut être patient mais ça se fait bien avec les schémas du pinout System 16 et Jamma sous le coude.

Sinon en attendant de te trouver une borne tu peux déjà acheter un supergun. Au moins tu pourras tester ton jeu. D'ailleurs si ton supergun possède des borniers à vis tu pourras y brancher tes fils sans adapateur ni soudure.
#64
Bootlegs / Bootleg PCB Shinobi
Vendredi 10 Février 2023, 17:30:53 PM
Citation de: Little_Rabbit le Vendredi 10 Février 2023, 14:25:05 PMComme le connecteur encartable est branché sur le PCB, on ne voit pas bien : mets-nous une photo du PCB seul. Mais à première vue comme ça, le PCB m'a bien l'air d'être en JAMMA (connecteur 2 x 28 broches).

Attention j'ai un Wonder Boy 3 bootleg en 2x28 mais c'est pas du Jamma mais du System 16. Comme à la base Shinobi c'est aussi du System 16 je ne pense pas que ce soit du Jamma. A vérifier avec la photo.