Voir les contributions

Cette section vous permet de consulter les contributions (messages, sujets et fichiers joints) d'un utilisateur. Vous ne pourrez voir que les contributions des zones auxquelles vous avez accès.


Messages - Teclis01

Pages: [1] 2 3 4 5 6 7
1
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Lundi 20 Juillet 2020, 12:08:55 pm »
Bon! j'ai commencé et déjà ça part mal XD
Je précise les arduino sont soudés sur la carte.

Quand je branche l'usb:

Sur une carte ca allume les 2 arduino uno
Sur l'autre carte aucun des arduino ne s'allume! j'avais mis le Pic a l'envers... je l'ai enlevé en cassant une patte malgré avoir retiré la soudure... retourné, resoudé mais pareil. Tu fais du SAV? ;)

Sur Arduino IDE j'ai importé la lib et chargé le fichier ino.
Sur la carte sur lesquels les arduinos s'allument quand je branche j'ai uploadé le ino... je vais donc continuer deja avec celle qui reponds!

2
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 25 Juin 2020, 16:22:12 pm »
J'attends mes RPi 4 pour tester! J'ai fini le montage des 2 kits. Si vous avez coupé trop court comme moi vous pouvez utiliser le cable d'alimentation d'un ventilo de PC.

3
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 20:09:22 pm »
C'est ma faute parce que j'ai pas lu  :-((
En plus j'ai répondu à ces bout en train en pensant les aider... Pire que des gosses   =:)) ;D
En fait je n'avais pas de RPi a disposition du coup... j'ai coupé à la moitié en me disant que je serais moitié bon moitié pas bon mais j'ai eu un doute en regardant le GPIO et des photo de RPi.
Au pire ce n'est pas bien grave je dois avoir ce genre de cable ou je sacrifierai 3 dupont ou je regarderai dans mon bazar informatique si qqch correspond.

4
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 19:06:10 pm »
C'est un running gag?
J'ai fini le montage... En espérant ne pas m'être planté.
Il manquait 1 pin sur les pin en L donc j'ai utilisé d'autre que j'avais droit

https://drive.google.com/file/d/1hcIWyKMHg-p3gUhQ71YxbZZrmVGah5Ep/view?usp=sharing

Pour le test je vais devoir me choper un Pi et configurer tout ça!

Edit: le jack est surement trop court

5
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 16:00:03 pm »
:D
J'espère ne pas être le seul gland à demander ^^

6
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 15:29:43 pm »
ça devrait le faire! J'etais tellement content en ouvrant la boite en plus tout est prêt c'est tellement agréable. Tu as du bien te faire chier à tout préparer, commandes, packaging, envois, ...etc donc j'en profite pour te remercier encore!

7
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 15:24:31 pm »
Mes plus plates excuses! J'ai raté le message :(
Je dois l'avouer j'avais complétement oublié de regarder le topic. Mea culpa! Gomenasai!

8
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 14:46:22 pm »
Ah j'ai un petit soucis!
Je n'ai pas fini de monter mais j'ai 5 * 100R et à priori il en faut 6 (R19,R20,R21,R25,R26,R27).
Mes 2 kits n'en ont que 5 donc je vais piquer sur le 2eme kit mais il m'en manquera 2 au 2 eme.
Autre point le 74LS08 a été remplacé par un SN74HC08N sans incidence à priori
Je continue le montage!

9
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Jeudi 11 Juin 2020, 13:33:04 pm »
Colis reçu!

10
Jamma, cablages, contrôleurs, interfaces & hacks / ZeroKey PIC Netdimm
« le: Jeudi 16 Avril 2020, 16:02:58 pm »
Mon sujet n'a pas attiré les foules mais j'ai avancé!
J'ai utilisé un autre programmeur de PIC (K150) et la programmation (par défaut) posait également problème.
J'ai désactivé dans le menu de fuses/fusibles l'option "PWRTE"... et là miracle!
Après test ça fonctionne parfaitement.

ça me dépasse...

11
Hacks / [WIP] Projet Open-Source : Le Pijama
« le: Dimanche 29 Mars 2020, 01:22:18 am »
Partant pour 2 kits à souder

12
Jamma, cablages, contrôleurs, interfaces & hacks / ZeroKey PIC Netdimm
« le: Samedi 28 Mars 2020, 18:34:26 pm »
Coucou ici,

Avec le confinement je me suis sorti les doigts et j'ai voulu tester le Piforce web (https://github.com/dev-tty0/Piforce-Web)
J'ai donc pris une mobo Naomi 2, une netdimm et ai préparé un bios et un ZeroKey.
Pour le bios j'ai fait un multi region et ai configuré la netdimm
Je branche tout et pouf ca marche avec Ikaruga. Motivé je mets quelques roms dont GW2 et CvS.
Et là survient le drame... ça charge... les écrans de lancement du jeu défilent, mais "reboot" de la Naomi pour arriver sur une error 33 Gateway not found.
Beaucoup d'articles disent que le problème viendrait du zerokey...

J'ai demandé à un membre le hex du zerokey car a priori c'est le zerokey le probleme mais pareil!
Le membre m'a dit qu'il n'avait pas réussit a burner le pic avec un wellon... Or j'ai un wellon VP390.

Du coup je me tourne vers vous pour savoir si il y a une config speciale car j'ai du l'ouvrir deja 40 fois tout nettoyer minutieusement, switcher la RAM, re-burner un zero key... mais rien n'y fait.
Qqun a t'il réussit à burner un zerokey avec un programmeur wellon et si oui y'a t'il une config spéciale?

Merci de m'avoir lu!

13
Alimentation, Electricité / Konami GN845 et -5V
« le: Mercredi 14 Novembre 2018, 21:58:14 pm »
Petit retour!
J'ai commandé des TLP621-4
Je vais relire ton explication a tête reposée car je ne comprends pas tout (c'est aussi du a mon incompetance en electronique)

CN2,3,4,5 sont les connecteurs ou sont brancher les 4 pieds (4 contacts pour chaque) et les lumières de ces pieds.
CN 1 est l'arrivé du jamma et donc du 5V pour les contrôles.

tu as branché quelque chose de mauvais sur CN1 et suite à ça tu as 2 directions qui ne fonctionne plus c'est ça ? => oui, enfin je ne sais pas s'ils fonctionnaient avant mais je subodore que oui.
Le problème c'est que l'entrée est piloté par un (micro processeur?) xilink qui va définir d'envoyer ou non la commande selon certains paramètres (notamment si un des 4 contacts d'un pied est appuyé).
Mon appareil USB est une interface jamma comme un JPAC mais j'ai pris la pcb est soudé sur un jamma male

14
Alimentation, Electricité / Konami GN845 et -5V
« le: Vendredi 09 Novembre 2018, 00:33:23 am »
Petit update après quelques essais.
En charge (PCB alimenté) sans aucuns inputs

J'ai testé les 4 transistors mais... rien c'est normal après avoir suivi les pistes c'est pour l'éclairage
j'ai donc testé les SN74HC14N
pin 1 : 5
pin 2 : 0
pin 3 : 5
pin 4 : 0
pin 5 : 5
pin 6 : 0
pin 7 : 0V (GND)
pin 8 : 0
pin 9 : 5
pin 10 : 0
pin 11 : 5
pin 12 : 5
pin 13 : 0
pin 14 : VCC (5V)

Le spin 11 et 12 me chiffonnent un peu je teste donc les 4 SN74HC14N  et ils ont tous le même comportement, donc je considère ça normal

Ensuite...
J'ai des tensions très étranges aux bornes 1-2 et 7-8 de l'optocoupleur.
Entre 1-2 : 1.1V
Entre 3-4 : 0V
Entre 5-6 : 0V
Entre 7-8 : 1.1V
Ce qui veut dire que j'alimente la diode qui active peut être de transistor et provoque donc l'information de l'input présent.

Ces diodes sont controlées par le xilinx (XC9536)
https://www.xilinx.com/support/documentation/data_sheets/ds064.pdf
Je ne trouve pas le pinout exact de ce composant...
http://dangerousprototypes.com/docs/images/2/2a/Quick-start-xc9572xl-baslc.png
OU
http://www.cs.ucf.edu/~ahossam/2004/cpld/software/images/webpack16.jpg
Dans les 2 cas ça se ressemble beaucoup.

Petite parenthèse je ne pensais pas retrouver du VHDL dans une pcb arcade!

Je doute que certaines fonctions du xilinx soit altérées donc je penche sérieusement pour l'optocoupleur côté led comme l'avait conseillé aganyte.

Prochaine étape desoudage double couche de ce composant... mais avant quelques vidéos de tuto pour savoir comment faire XD


15
Alimentation, Electricité / pbl alim naomi
« le: Jeudi 08 Novembre 2018, 12:01:14 pm »
Pour compléter...
Le 3eme alimente l'IO d'une NUC (par exemple)
Mais le système Naomi n'a besoin que des 2 premiers connecteurs et là impossible de se planter.

16
Alimentation, Electricité / Konami GN845 et -5V
« le: Jeudi 08 Novembre 2018, 11:58:57 am »
Après de nouveaux tests j'ai remarqué des comportements bizarres.
Je dois vérifier à tête reposée histoire de pas dire nawak.
J'ai omis de dire que 2 fonctionnent sur les 4 inputs.

Je mets ici les liens vers les composants qui composent la PCB, ça pourra etre utile à d'autres et ça me permets de garder un suivi :)
Les trucs bleux ZJS5101
https://www.tyro-teq.com/ds/pdf/z/0066/ZJSR510122201.pdf
L'optocoupleur TLP621−4
http://www.mouser.com/ds/2/408/TLP621_datasheet_en_20071001-739144.pdf
BI D91A & BI D91C
http://www.farnell.com/datasheets/93254.pdf?_ga=2.235492289.1173089800.1541674373-867475212.1541674373
SN74HC14N
http://www.ti.com/lit/ds/symlink/sn74hc14.pdf

Pages: [1] 2 3 4 5 6 7