Auteur Sujet: [WIP] Atari Breakout de 1976  (Lu 44690 fois)

En ligne olschool

  • ✌(◕‿◕)✌ Donateur 2018
  • Hi-Score Buster
  • *
  • Messages: 3029
  • Localisation: nice
  • Le JR's est Immortel
    • Voir le profil
    • Le JR's
[WIP] Atari Breakout de 1976
« Réponse #48 le: Samedi 11 Septembre 2010, 12:49:06 pm »
  •  ^-
    Toujours un plaisir de te lire même si à mon tout petit niveau je ne  comprend pas tout !!!

    Encore bravo le démon des pannes viens d'en perdre encore une

     ;)
    Winner's Don't Use Drug mais ça aide quand même pour finir Ghost & Goblins.


    Recherche Bornes: Punch Out


    En rentrant le camion au garage,  je me suis aperçu que j avais récupérer une after burner  ;D

    Hors ligne f4brice

    • ✌(◕‿◕)✌ Donateur 2018
    • Arcade Kingmaster
    • *
    • Messages: 4112
    • Localisation: Besançon (prononcez "B'zançon")
    • « Matériel inconnu ? Touche à ton cul ! »
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #49 le: Samedi 11 Septembre 2010, 13:29:15 pm »
  • Comment ce fait il que tu ai autant de portes logiques mortes ?

    Le PCB a souffert d'un problème d'alim. C'est dommageable pour les composants TTL, surtout les premières générations.

    Aucune n'a eu la chance de faire fusible pour protéger les autres ?

    Non, ça ne marche pas du tout comme ça.

    Une demi-douzaine de cramées, c'est déjà beaucoup non ?

    Non, sachant qu'il y a des séries à problèmes : 7408, 7474, 74193.  ;)

    Hors ligne maldoror68

    • Dieu de l' Arcade
    • *
    • Messages: 8072
    • Localisation: Mulhouse
    • voui, c'est moi ki lai fait^^allez voir mon string
      • Voir le profil
      • pixels points morts
    [WIP] Atari Breakout de 1976
    « Réponse #50 le: Samedi 11 Septembre 2010, 13:39:33 pm »
  • ces wip se dégustent toujours avec plaisir.

    aux chiottes le démon des pannes !  :D

    peux tu nous présenter les différents modes de jeu ?  =?=j'ai l'impression qu'il y a plein de modes différents  :-\

    Hors ligne Bal

    • Historical Gamer
    • *
    • Messages: 4254
    • Localisation: Hanzinne
      • Voir le profil
      • Darkmoon
    [WIP] Atari Breakout de 1976
    « Réponse #51 le: Samedi 11 Septembre 2010, 13:52:14 pm »
  • je sais pas quoi dire d'autre que: FANTASTIC FAB est de retour, le démon n'a qu'à bien se tenir, sur ce coup là, chapeau !

    vivement le son, parce que là, ca fait un peu vide, mais j'adore trop ta tite télé pour tester, pratique à fond en fin de compte ^^

    BAL.
     ^-^



    Hors ligne Elesias

    • Pratiquement VIP
    • *
    • Messages: 1275
    • Localisation: Lançon Provence
    • Borne to be wild
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #52 le: Samedi 11 Septembre 2010, 14:13:38 pm »
  • Pffiou, impressionnant. Bien joué, encore une fois  ^-
    Recherche bornes : Q*Bert - Zaxxon - Dig Dug - Pole Position - Turbo (de SEGA) - Subroc - Lady Bug - Tron - Gorf - Carnival - Time Pilot (et oui, rien que ça ! ^^)



    Hors ligne speedsterharry

    • Pratiquement VIP
    • *
    • Messages: 1261
    • Localisation: Lyon
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #53 le: Samedi 11 Septembre 2010, 14:46:56 pm »
  • Yes ! Encore une carte sauvée ! La prochaine, c'est une pole position II ? :ang:

    Hors ligne f4brice

    • ✌(◕‿◕)✌ Donateur 2018
    • Arcade Kingmaster
    • *
    • Messages: 4112
    • Localisation: Besançon (prononcez "B'zançon")
    • « Matériel inconnu ? Touche à ton cul ! »
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #54 le: Mercredi 15 Septembre 2010, 22:57:22 pm »
  • Bonsoir.

    Voici une mise à jour de ce WIP.

    Il est temps maintenant de ré-intégrer le PCB dans la borne.
    Mais avant de faire ça, je vais faire ce que je ne fais jamais habituellement : une modification du fonctionnement original du PCB...
    D'habitude, je cherche à remettre tous mes PCB dans le même état fonctionnel qu'à la sortie de l'usine.
    Pour ce PCB, je vais faire presque une exception.
    Il va subir une petite modification...

    Préparation du composant que je vais greffer :


    Le composant est maintenant greffé et connecté :


    Mes fils sont beaucoup plus discrets que les fils Atari utilisés pour la modification liée au générateur de murs de briques...

    J'ai besoin de fixer un petit interrupteur à 2 positions :


    Voilà, la modif du PCB est finie :


    Quel est l'objet de la modif, à quoi sert-elle ? Mystère !  ;)


    Maintenant, je vais m'occuper de pouvoir reconnecter le PCB dans la borne.
    Le problème, c'est que 2 pistes du connecteur de bord de carte ont complètement brûlé. Elles sont totalement inutilisables.
    J'ai un peu de chance : il s'agit des 2 pistes de masse, utilisées pour le retour de l'alim.
    Il existe d'autres pistes de masses sur le PCB encore utilisable.

    Déjà, je nettoie à fond les pistes pour les désoxyder complètement.
    La première étape consiste en un frottement énergique avec une brosse à dents et de l'alcool à brûler :


    Deuxième étape : nettoyage énergique avec un chiffon et de l'alcool à brûler.
    Une action mécanique est nécessaire pour bien virer la couche d'oxydation présente en surface des pistes :


    Enfin, je finis même avec un petit morceau de papier de verre (grain très fin) pour nettoyer les pistes qui recoivent l'alimentation car ce sont les pistes les plus sollicitées.

    Voici le connecteur femelle de la borne, dans lequel vient s'enficher le PCB :


    En (1), ce sont les 2 broches situés au niveau de la piste brûlée sur le PCB.
    Elles sont foutues. Le plastique ayant chauffé et fondu, ces broches sont maintenant engluées dedans.
    En (2), ce sont les 2 × 2 broches de l'alim. On voit qu'elles sont bien fatiguées, quand on les compare avec des broches plus à gauche...

    Avoir nettoyé le connecteur mâle sur le PCB ne sert à rien si le connecteur femelle présent dans la borne n'est pas lui aussi nettoyé.
    Et il y a du boulot...

    Pour éviter tout futur problème, je vais débrocher les broches fatiguées et les changer.
    Il y a sur le connecteur de nombreuses broches inutilisées et encore en bon état.

    Voici une des 4 broches d'alim sortie du connecteur.
    On voit des traces d'oxydation et peut-être d'arc électrique :


    Je débroche donc des broches inutiles mais en bon état :


    Ensuite je remplace ainsi une par une les broches mortes pour lesquelles un bon état est nécessaire (beaucoup de courant va passer par là).


    En (1), j'ai déjà remplacé 2 broches d'alim.
    En (2), ce sont 2 broches que je n'ai pas encore remplacées.
    en (3), il y a un trou car c'est là que j'ai récupéré une des broches en bon état pour greffe.

    Une fois ce long et fastidieux (mais indispensable) travail de changement de broches terminé, je peux enfin rebrancher le PCB avec des pistes toutes propres sur un connecteur ayant des broches toutes propres aussi...

    Mise en route de la borne.
    Après d'interminables secondes (le tube est vraiment beaucoup plus long que les autres à chauffer), l'image apparaît enfin :


    L'image est de bonne qualité, mais il y a un problème flagrant de rotation...
    Sur un tube noir & blanc, il est très facile de régler ce genre de problème sans se prendre la tête...
    Il suffit de tourner le bloc déviateur complet :


    D'ailleurs, j'ai entouré en vert sur la photo les traces de vernis rouge qui est barbouillé à l'usine.
    Le décalage est bien visible. Le tube n'a jamais été monté comme ça à l'usine.
    Encore un gugus qui n'aura pas respecté la devise sous mon avatar et qui aura fait n'importe quoi...

    Après petite correction, l'image est excellente :


    Sauf que, comme prévu, je constate que le PCB souffre encore d'un problème... audio !
    Dès que la balle touche une brique, normalement il y a un petit bruit qui accompagne la disparition de la brique et l'incrément du score.
    Ce "petit" bruit, en fait, s'arrête quand il a envie. Et c'est particulièrement agaçant.

    Je dois donc déplacer mon oscillo et dépanner "sur site" :


    Il se trouve que le problème est assez simple à diagnostiquer.


    Le son de la brique est commandé par un monostable (A8) dont la sortie, lorsqu'elle est active, laisse passer le signal "BRICK SOUND".
    Bien entendu le monostable est bloqué en attract mode.
    Ce monostable est commandé via un circuit compteur / décompteur F6, entouré en rouge.
    À chaque brique effacée, le compteur est incrémenté d'un certain nombre d'unités (qui dépend de la position de la brique).
    Le circuit autour du compteur fait en sorte que ce dernier cherche à revenir à son point d'équilibre qui est la valeur 15.
    Ainsi, si une brique à 4 points est touchée, le compteur est incrémenté de 4 : 15 => 0 => 1 => 2 => 3.
    Il va spontanément se décrémenter jusqu'à repasser de 0 à 15 : 3 => 2 => 1 => 0 => 15 (il boucle).
    Cette décrémentation se fait à raison d'une unité par image affichée.
    Le monostable est commandé 4 fois.

    Il se trouve que ce compteur est à moité mort et fait un peu ce qu'il veut.
    Après changement du composant, tout rentre dans l'ordre...

    Ma borne Breakout est maintenant pleinement réparée !  :-*


    Il n'y a plus grand chose à faire sur ce WIP.
    Le dernier point, c'est la mise en place d'un micro-switch pour détecter les pièces qui passent en tirelire.
    Le précédent proprio l'a viré complètement et a installé un bouton-poussoir à la place.
    J'ai remis un monnayeur qui accepte les pièces de 1 FRF, mais je n'ai pas de micro-switch en rab pour le moment...

    Hors ligne atarimania

    • Scotché
    • *
    • Messages: 454
    • Localisation: Atariland
      • Voir le profil
      • Atarimania
    [WIP] Atari Breakout de 1976
    « Réponse #55 le: Mercredi 15 Septembre 2010, 23:08:47 pm »
  • Toujours aussi impressionnant... je n'ai qu'un mot à dire.... BRAVO !!!!!!!

    Hors ligne Wapata

    • Game Cheater
    • *
    • Messages: 2499
    • Localisation: A la frontière du 44 et du 56
    • En fin de vie arcadienne.
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #56 le: Jeudi 16 Septembre 2010, 07:54:07 am »
  • Et tu crois que tu va pouvoir clore se topic sans nous indiquer à quoi sert le switch et le composant greffé sur la PCB ? :D

    Hors ligne f4brice

    • ✌(◕‿◕)✌ Donateur 2018
    • Arcade Kingmaster
    • *
    • Messages: 4112
    • Localisation: Besançon (prononcez "B'zançon")
    • « Matériel inconnu ? Touche à ton cul ! »
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #57 le: Jeudi 16 Septembre 2010, 08:19:48 am »
  • Et tu crois que tu va pouvoir clore se topic sans nous indiquer à quoi sert le switch et le composant greffé sur la PCB ? :D

    J'offre un paquet (virtuel) de CHOCAPIC™ à la première personne qui trouve à quoi sert ma modification.  :D

    Un indice :
    • la modification est active et visible sur la dernière vidéo que j'ai postée

    Hors ligne naudnaud

    • Pilier
    • *
    • Messages: 744
    • Localisation: Métabief dans le Doubs
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #58 le: Jeudi 16 Septembre 2010, 08:29:53 am »
  • La raquette ne but plus sur les coter ??


    Sinon j'adore ta borne et surtout Breakout !!!! :-* :-*
    Forum sur la Dingoo A320
    http://dingoo.forumactif.net/

    Hors ligne HI

    • Game Cheater
    • *
    • Messages: 2451
    • Localisation: IDF
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #59 le: Jeudi 16 Septembre 2010, 08:50:52 am »
  • nickel ça donne envie :)

    Hors ligne Wapata

    • Game Cheater
    • *
    • Messages: 2499
    • Localisation: A la frontière du 44 et du 56
    • En fin de vie arcadienne.
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #60 le: Jeudi 16 Septembre 2010, 08:57:32 am »
  • Mmmm, plus on frappe la bille (=plus longtemps on reste en vie), plus la bille accélère ?

    Hors ligne f4brice

    • ✌(◕‿◕)✌ Donateur 2018
    • Arcade Kingmaster
    • *
    • Messages: 4112
    • Localisation: Besançon (prononcez "B'zançon")
    • « Matériel inconnu ? Touche à ton cul ! »
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #61 le: Jeudi 16 Septembre 2010, 09:00:27 am »
  • La raquette ne but plus sur les coter ??

    Si...

    Mmmm, plus on frappe la bille (=plus longtemps on reste en vie), plus la bille accélère ?

    Exact, mais ça faisait déjà partie du fonctionnement standard.
    De plus, quand la balle touche le mur du haut, la raquette se rétrécit !!!

    Ma modif n'est pas liée à ce comportement.  :)

    Hors ligne Wapata

    • Game Cheater
    • *
    • Messages: 2499
    • Localisation: A la frontière du 44 et du 56
    • En fin de vie arcadienne.
      • Voir le profil
    [WIP] Atari Breakout de 1976
    « Réponse #62 le: Jeudi 16 Septembre 2010, 09:15:47 am »
  • C'est quand même pas la loupiotte du Serve Button qui reste allumée tant que la bille n'est pas partie ?
    Ca rend bien les bandes de couleur en tout cas.

    (et au fait, félicitations pour tout le boulot hein ? J'ai oublié de l'dire !)

    Hors ligne Bal

    • Historical Gamer
    • *
    • Messages: 4254
    • Localisation: Hanzinne
      • Voir le profil
      • Darkmoon
    [WIP] Atari Breakout de 1976
    « Réponse #63 le: Jeudi 16 Septembre 2010, 09:36:32 am »
  • Auto-serve et manual serve par hasard ?