Auteur Sujet: [WIP] G2N - USB Version  (Lu 35193 fois)

Hors ligne aje_fr

  • Famille
  • *
  • Messages: 1159
    • Voir le profil
[WIP] G2N - USB Version
« Réponse #96 le: Mardi 30 Juillet 2013, 18:46:20 pm »
  • Sauf que les lignes I2C du pic sont spécifiquement prévu pour tourner avec différentes tensions (lis la doc)
    Je m'incline alors, et les résistances de tirage ?
    A+
    Think different, don't purchase Apple !

    Hors ligne MaKoTo

    • Passionné
    • *
    • Messages: 190
      • Voir le profil
      • http://makotoworkshop.org
    [WIP] G2N - USB Version
    « Réponse #97 le: Mardi 30 Juillet 2013, 18:50:39 pm »
  • J'obtiens ces mesures avec ou sans camera.
    cependant, il s'agit d'une wiimote sans motion plus, modèle RVL-003.

    Je cherche à réduire le champ d'action pour circonscrire le problème suivant :
    La main board, sans la pistol board connectée, passe outre le message d'erreur I2C et se met en mode run.

    Quelques images pour faire joli,
    Le circuit avec le strict minimum :
    Ici avec un résonateur @12MHz.


    On peut voir SCL qui vit sa vie, calibre 100µs


    SCL calibre 10µs.


    Là je branche la résistance de SDA, et SCL passe à 0.
    Si je déconnecte cette résistance de pull-up, SCL reste à 0.
    Le signal sur SCL revient après un Reset du PIC à condition que la pin 15 (SDA) reste en l'air.


    Si donc aganyte, dans ces conditions de mesures, ce n'est pas normal, je tenterais demain avec le second PIC.


    « Modifié: Mardi 30 Juillet 2013, 18:52:29 pm par MaKoTo »
    http://makotoworkshop.org/

    Message tapé en bépo sur un clavier orthogonal TypeMatrix
    Sous GNU/Linux Ubuntu

    Hors ligne Aganyte

    • ✌ Donateur depuis 2018 WIPeur compulsionnel
    • Staff
    • Dieu de l' Arcade
    • *****
    • Messages: 6624
    • Localisation: 83 Saint maximin la Sainte Baume
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #98 le: Mardi 30 Juillet 2013, 19:00:32 pm »
  • Je m'incline alors, et les résistances de tirage ?
    A+

    Pour les résistances de tirages, c'est une valeur que j'ai trouvé sur plusieurs schémas sur le net (et qui colle aussi avec ce qui est donné sur WIKI sur le chapitre I2C)

    Hors ligne Aganyte

    • ✌ Donateur depuis 2018 WIPeur compulsionnel
    • Staff
    • Dieu de l' Arcade
    • *****
    • Messages: 6624
    • Localisation: 83 Saint maximin la Sainte Baume
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #99 le: Mardi 30 Juillet 2013, 19:03:22 pm »
  • Sinon, si le changement de pic ne donne rien, je persiste dans l'idée d'essayer une autre caméra.

    Hors ligne Iro

    • Alias le Rouston Masqué
    • Staff
    • Passionné
    • *****
    • Messages: 184
    • Localisation: Chilly Mazarin
    • Iro, chevalier Judaï
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #100 le: Jeudi 01 Août 2013, 14:14:20 pm »
  • En parcourant le topic du G2N sur arcade area , je suis tombé sur le probléme que j'ai eu.
    De ce que j'expliquais , j'avais un comportement aléatoire :
    "Je comprends rien , J'ai tout essayé , tout vérifié : I2C Error
    Mais j'ai déja reussi avoir le blob puis plus rien
    J'ai eu aussi : Error puis loading config ...
    J'ai raccourci les fils : Error
    J'ai vérifié les pistes , tout semble normal "


    Aganyte me demande :
    "Vérifie aussi ton 3.3v, ainsi que la sortie de l'oscillateur (tu dois avoir environ 2,5v) et pourquoi pas le 3.3v sur la broche Reset."
    Résultat :  - 3,5V pour le 3,3V
                - 3,8V sur la pin d'alimentation de la caméra
                - 2,4V sur l'oscillateur
                - 2,3V sur le reset (pin8) de la camera.

    Réponse d'Aganyte :
    "t'as clairement pas assez de patate sur la pin 8, ton condo fout la grouille !!"

    Donc changeage par un condensateur polarisé de 10µf et de 3 résistances en série pour faire 220ohms


    Et depuis tout roule.

    Je viens de câbler la caméra sur la Mainboard V2 , je vois bien les blobs et pas de I2C Error.






    Et mon 1er probléme
    "Donc sur la mainboard , c'est forcement le pic qui ne démarre car il n'est pas alimenté.
    Je zieute les 3 pins et vois que j'ai fait un gros paté de soudure sur un des condos du quartz : le pâté touchait le plan de masse"

    A ce stade , avec le contraste au bon niveau, je n'avais que des carré blanc sur le LCD
    « Modifié: Jeudi 01 Août 2013, 14:23:12 pm par Iro »
    "Jet set 2, c'est avec Robert Garcia ?" Kaneda, Lapsus de sac Vol.1
    Peter Shou Owner' Club

    WIPs : Naomi - SEGA Rally - AB Cop - Lethal Enforcers - COMPUMI - Terminator 2 - Space Invaders - Artworks pour Boitiers K7 Naomi CF - Ma collec' de panels

    LES TUTOS DE GAMO   

    Hors ligne MaKoTo

    • Passionné
    • *
    • Messages: 190
      • Voir le profil
      • http://makotoworkshop.org
    [WIP] G2N - USB Version
    « Réponse #101 le: Jeudi 01 Août 2013, 19:05:23 pm »
  • Y'en a un qui marche c'est bien  ^-

    Alors, j'ai testé sur ma plaque labo avec mon second PIC, et le résultat est le même, le signal SCL s'écroule. Et sur la main board, tout est pareil.
    Donc je suppose que finalement c'est peut-être un phénomène normal, que si le signal SDA n'est pas présent, SCL finit par disparaître, puisque de toute manière le logiciel se met en erreur I2C.
    Donc j'étais partit sur une fausse piste.

    De plus j'ai remarqué que tous mes signaux sont bruités, y compris le 5V et le 3V, et pas moyen de  filtrer ça correctement ! j'ai trouvé le responsable… la caméra.  :?
    Sans elle, j'ai des signaux clean sur mes deux boards.  ::)

    Tous les signes convergeraient donc vers la piste de la camera défectueuse, et ce en dépit du fait qu'une fois remise en place sur sa wiimote, elle fonctionne très bien.
    Avez-vous des infos sur le fait qu'il existerait plusieurs version de la pixart ?
    N'ayant pas d'autre caméra IR sous la main, je m'apprêtais donc à mettre en œuvre un circuit de test à base d'arduino…

    À la lumière des nouveaux éléments indiqués par d'Iro, je vais tenter quelques petites choses avant, bien que le coup du 10µF et 220ohm n'ait rien donné…


    Iro, tu as refait une nouvelle PCB ? l'ancienne ne convenait pas ?
    Et merci pour ton retour d'XP  <:)
    « Modifié: Jeudi 01 Août 2013, 19:09:17 pm par MaKoTo »
    http://makotoworkshop.org/

    Message tapé en bépo sur un clavier orthogonal TypeMatrix
    Sous GNU/Linux Ubuntu

    Hors ligne Iro

    • Alias le Rouston Masqué
    • Staff
    • Passionné
    • *****
    • Messages: 184
    • Localisation: Chilly Mazarin
    • Iro, chevalier Judaï
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #102 le: Vendredi 02 Août 2013, 07:40:16 am »
  • La nouvelle intègre les modifications pour le PC.
    "Jet set 2, c'est avec Robert Garcia ?" Kaneda, Lapsus de sac Vol.1
    Peter Shou Owner' Club

    WIPs : Naomi - SEGA Rally - AB Cop - Lethal Enforcers - COMPUMI - Terminator 2 - Space Invaders - Artworks pour Boitiers K7 Naomi CF - Ma collec' de panels

    LES TUTOS DE GAMO   

    Hors ligne MaKoTo

    • Passionné
    • *
    • Messages: 190
      • Voir le profil
      • http://makotoworkshop.org
    [WIP] G2N - USB Version
    « Réponse #103 le: Lundi 05 Août 2013, 17:47:29 pm »
  • Bonne nouvelle !
    J'ai réussis à établir le dialogue entre la « main board » et la camera, sans passer par la « pistol board », mais en utilisant les signaux d'horloge, d'alim et de reset provenant de la « wiimote » elle même !
    J'aurais du y penser plus tôt  >:(

    J'ai donc une assez bonne idée du problème et vais travailler sur une nouvelle version de la « pistol board », avant de me prononcer.

     :-)=
    http://makotoworkshop.org/

    Message tapé en bépo sur un clavier orthogonal TypeMatrix
    Sous GNU/Linux Ubuntu

    Hors ligne Aganyte

    • ✌ Donateur depuis 2018 WIPeur compulsionnel
    • Staff
    • Dieu de l' Arcade
    • *****
    • Messages: 6624
    • Localisation: 83 Saint maximin la Sainte Baume
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #104 le: Lundi 05 Août 2013, 22:47:45 pm »
  • J'ai hâte de savoir pourquoi tu as eu temps de soucis la ou je n'ai rien remarqué (sur 3 camera différentes en plus)  ;) ^-

    Hors ligne MaKoTo

    • Passionné
    • *
    • Messages: 190
      • Voir le profil
      • http://makotoworkshop.org
    [WIP] G2N - USB Version
    « Réponse #105 le: Vendredi 16 Août 2013, 16:20:58 pm »
  • Problème résolu !  ^-^

    L'horloge et le reset volé à la wiimote ayant permis un fonctionnement correct, je me suis tourné vers l'oscillateur à quartz 25Mhz, qui, une fois la caméra IR connectée au circuit provoquait un méchant parasitage du 5V, et donc du 3,3V , induisant alors tous les soucis de communications.

    La caméra fonctionnant en 3,3V, je me suis dit qu'elle pourrait ne pas apprécier de manger une horloge à 5V.

    J'ai donc commandé (d'où l'attente) un oscillateur à quartz alimenté en 3,3V @25Mhz (le 24MHz, comme la wiimote étant difficile à trouver).
    http://www.ebay.fr/itm/OSCILLATOR-FREQUENCY-25MHZ-Part-ACHL-25-000MHZ-EK-/390614555141?pt=UK_BOI_Electrical_Components_Supplies_ET&hash=item5af2711a05#shId

    Mis en place sur la pistol board, après l'allumage, la communication passait bien après un ou deux «reset» manuel du PIC…
    J'ai alors remis les valeurs de R3=220 et C3=10µF sur le circuit de reset de la cam, et dés l'allumage ça marche !

    Merci à vous pour votre aide et votre patience  <:)
    Je vais enfin pouvoir raccorder un pad USB et continuer la mise en œuvre !
    « Modifié: Vendredi 16 Août 2013, 20:11:17 pm par MaKoTo »
    http://makotoworkshop.org/

    Message tapé en bépo sur un clavier orthogonal TypeMatrix
    Sous GNU/Linux Ubuntu


    Hors ligne MaKoTo

    • Passionné
    • *
    • Messages: 190
      • Voir le profil
      • http://makotoworkshop.org
    [WIP] G2N - USB Version
    « Réponse #107 le: Vendredi 16 Août 2013, 18:24:51 pm »
  • Ça je l'ignore, peut-être suis-je tombé sur une mauvaise série de quartz «parasiteur».
    J'ai pourtant essayé de croiser à nouveau, en remettant le quartz 5V sur la PCB, mais rien à faire.
    http://makotoworkshop.org/

    Message tapé en bépo sur un clavier orthogonal TypeMatrix
    Sous GNU/Linux Ubuntu


    Hors ligne Iro

    • Alias le Rouston Masqué
    • Staff
    • Passionné
    • *****
    • Messages: 184
    • Localisation: Chilly Mazarin
    • Iro, chevalier Judaï
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #109 le: Vendredi 16 Août 2013, 19:29:36 pm »
  • bonne nouvelle !!
    Sur ton schéma, ton quartz est noté 24mhz et tu dis avoir fait tes tests avec un 24. Et çà fonctionne finalement avec un 25 ... Alors que les specs d'Aganyte donne un 25 et c'est celui que nous avons utilisé. çà ne viendrait pas de là ?
    "Jet set 2, c'est avec Robert Garcia ?" Kaneda, Lapsus de sac Vol.1
    Peter Shou Owner' Club

    WIPs : Naomi - SEGA Rally - AB Cop - Lethal Enforcers - COMPUMI - Terminator 2 - Space Invaders - Artworks pour Boitiers K7 Naomi CF - Ma collec' de panels

    LES TUTOS DE GAMO   

    Hors ligne MaKoTo

    • Passionné
    • *
    • Messages: 190
      • Voir le profil
      • http://makotoworkshop.org
    [WIP] G2N - USB Version
    « Réponse #110 le: Vendredi 16 Août 2013, 20:14:32 pm »
  • oups désolé y'a confusion, je parle de l'oscillateur à quartz, j'édite mon post de suite…
    La wiimote fournit du 24MHz, mais comme c'est difficile à trouver, le 25MHz fait aussi bien l'affaire puisque ça reste dans la tolérance de la camera IR.
    http://makotoworkshop.org/

    Message tapé en bépo sur un clavier orthogonal TypeMatrix
    Sous GNU/Linux Ubuntu

    Hors ligne aje_fr

    • Famille
    • *
    • Messages: 1159
      • Voir le profil
    [WIP] G2N - USB Version
    « Réponse #111 le: Vendredi 16 Août 2013, 23:12:59 pm »
  • Intéressant, mais comment ce fait t'il que ni Iro ni moi n'avons eu de problème de com ?
    La différence entre théorie et pratique et selon le théorème d'Einstein :

    « La théorie, c'est quand on sait tout et que rien ne fonctionne. La pratique, c'est quand tout fonctionne et que personne ne sait pourquoi. Ici, nous avons réuni théorie et pratique : Rien ne fonctionne... et personne ne sait pourquoi !  »
    Think different, don't purchase Apple !